<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<meta name="Generator" content="Microsoft Word 15 (filtered medium)">
<style><!--
/* Font Definitions */
@font-face
        {font-family:Wingdings;
        panose-1:5 0 0 0 0 0 0 0 0 0;}
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
@font-face
        {font-family:Consolas;
        panose-1:2 11 6 9 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0cm;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif;
        color:black;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:#0563C1;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:#954F72;
        text-decoration:underline;}
pre
        {mso-style-priority:99;
        mso-style-link:"Préformaté HTML Car";
        margin:0cm;
        margin-bottom:.0001pt;
        font-size:10.0pt;
        font-family:"Courier New";
        color:black;}
p.MsoListParagraph, li.MsoListParagraph, div.MsoListParagraph
        {mso-style-priority:34;
        margin-top:0cm;
        margin-right:0cm;
        margin-bottom:0cm;
        margin-left:36.0pt;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif;
        color:black;}
span.PrformatHTMLCar
        {mso-style-name:"Préformaté HTML Car";
        mso-style-priority:99;
        mso-style-link:"Préformaté HTML";
        font-family:Consolas;
        color:black;}
p.msonormal0, li.msonormal0, div.msonormal0
        {mso-style-name:msonormal;
        mso-margin-top-alt:auto;
        margin-right:0cm;
        mso-margin-bottom-alt:auto;
        margin-left:0cm;
        font-size:12.0pt;
        font-family:"Times New Roman",serif;}
p.msonormal00, li.msonormal00, div.msonormal00
        {mso-style-name:msonormal0;
        mso-margin-top-alt:auto;
        margin-right:0cm;
        mso-margin-bottom-alt:auto;
        margin-left:0cm;
        font-size:12.0pt;
        font-family:"Times New Roman",serif;
        color:black;}
p.msochpdefault, li.msochpdefault, div.msochpdefault
        {mso-style-name:msochpdefault;
        mso-margin-top-alt:auto;
        margin-right:0cm;
        mso-margin-bottom-alt:auto;
        margin-left:0cm;
        font-size:10.0pt;
        font-family:"Times New Roman",serif;}
span.emailstyle19
        {mso-style-name:emailstyle19;
        font-family:"Calibri",sans-serif;
        color:windowtext;}
span.prformathtmlcar0
        {mso-style-name:prformathtmlcar;
        font-family:Consolas;
        color:black;}
span.emailstyle22
        {mso-style-name:emailstyle22;
        font-family:"Calibri",sans-serif;
        color:#1F497D;}
span.spelle
        {mso-style-name:spelle;}
span.EmailStyle27
        {mso-style-type:personal-compose;
        color:#1F497D;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-size:10.0pt;}
@page WordSection1
        {size:612.0pt 792.0pt;
        margin:70.85pt 70.85pt 70.85pt 70.85pt;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->
</head>
<body bgcolor="white" lang="FR" link="#0563C1" vlink="#954F72">
<div class="WordSection1">
<p class="MsoNormal"><span style="color:#1F4E79;mso-style-textfill-fill-color:#1F4E79;mso-style-textfill-fill-alpha:100.0%"><span style="color:windowtext">Merci Hubert J<o:p></o:p></span></span></p>
<p class="MsoNormal"><span style="color:#1F4E79;mso-style-textfill-fill-color:#1F4E79;mso-style-textfill-fill-alpha:100.0%"><span style="color:windowtext"> <o:p></o:p></span></span></p>
<p class="MsoNormal"><span style="color:#1F4E79;mso-style-textfill-fill-color:#1F4E79;mso-style-textfill-fill-alpha:100.0%"><span style="color:windowtext">Je ne vais pas modifier mes
<span class="spelle">gpo</span> des <span class="spelle">waptdeploy</span> mais je vais retenir l’idée de forcer la reinstall via le package waptupgrade<o:p></o:p></span></span></p>
<p class="MsoNormal"><span style="color:#1F4E79;mso-style-textfill-fill-color:#1F4E79;mso-style-textfill-fill-alpha:100.0%"><span style="color:windowtext">Dans le setup.py du waptupgrade (<a href="https://github.com/tranquilit/WAPT/blob/master/waptupgrade/setup.py"><span style="color:#1F4E79;mso-style-textfill-fill-color:#1F4E79;mso-style-textfill-fill-alpha:100.0%">https://github.com/tranquilit/WAPT/blob/master/waptupgrade/setup.py</span></a>),
 j’ai vu une section force = False à la ligne 261 mais en fait cette variable étant en dehors de la fonction def install(), elle n’est donc pas prise en compte à la ligne 278 (if not force…..)<o:p></o:p></span></span></p>
<p class="MsoNormal"><span style="color:#1F4E79;mso-style-textfill-fill-color:#1F4E79;mso-style-textfill-fill-alpha:100.0%"><span style="color:windowtext">Ne serait-il pas mieux de déplacer force =…. à l’intérieur de def install() ?<o:p></o:p></span></span></p>
<p class="MsoNormal"><span style="color:#1F4E79;mso-style-textfill-fill-color:#1F4E79;mso-style-textfill-fill-alpha:100.0%"><span style="color:windowtext">Sinon, plus lisible mais plus crado, remonter force = au début du fichier mais la déclarer comme global….
<o:p></o:p></span></span></p>
<p class="MsoNormal"><span style="color:#1F4E79;mso-style-textfill-fill-color:#1F4E79;mso-style-textfill-fill-alpha:100.0%"><span style="color:windowtext">Bon week-end à tous !<o:p></o:p></span></span></p>
<p class="MsoNormal"><span style="color:#1F4E79;mso-style-textfill-fill-color:#1F4E79;mso-style-textfill-fill-alpha:100.0%"><span style="color:windowtext">Jordi<o:p></o:p></span></span></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal"><span style="color:#1F497D"> </span><o:p></o:p></p>
<div>
<div style="border:none;border-top:solid #E1E1E1 1.0pt;padding:3.0pt 0cm 0cm 0cm">
<p class="MsoNormal"><b><span style="color:windowtext">De :</span></b><span style="color:windowtext"> WAPT <wapt-bounces@lists.tranquil.it>
<b>De la part de</b> Hubert TOUVET<br>
<b>Envoyé :</b> jeudi 11 juillet 2019 14:20<br>
<b>À :</b> wapt@lists.tranquil.it<br>
<b>Objet :</b> Re: [Wapt] Migration Community -> Entreprise</span><o:p></o:p></p>
</div>
</div>
<p class="MsoNormal"> <o:p></o:p></p>
<p class="MsoNormal" style="margin-bottom:12.0pt">Bonjour,<br>
Effectivement, tu n'as rien moupé, c'est un problème que l'on a noté.<br>
Pour contourner, il faut faire une installation forcée...<br>
Sinon modifier le paquet waptupgrade pour inclure l'édition (community/enterprise) dans la vérification...<o:p></o:p></p>
<div>
<p class="MsoNormal">Le 10/07/2019 à 15:30, MORILLO Jordi a écrit :<o:p></o:p></p>
</div>
<blockquote style="margin-top:5.0pt;margin-bottom:5.0pt">
<p class="MsoNormal">Bonjour,<o:p></o:p></p>
<p class="MsoNormal"> <o:p></o:p></p>
<p class="MsoNormal">Je viens d’effectuer la migration en Entreprise mais c’est fort étrange :<o:p></o:p></p>
<p class="MsoListParagraph" style="text-indent:-18.0pt">-<span style="font-size:7.0pt;font-family:"Times New Roman",serif">         
</span>J’ai effectué convenablement l’update coté serveur<o:p></o:p></p>
<p class="MsoListParagraph" style="text-indent:-18.0pt">-<span style="font-size:7.0pt;font-family:"Times New Roman",serif">         
</span>J’ai désinstallé complètement wapt d’un poste de management puis j’ai réinstaller proprement à partir de waptsetup-tis.exe<o:p></o:p></p>
<p class="MsoListParagraph" style="text-indent:-18.0pt">-<span style="font-size:7.0pt;font-family:"Times New Roman",serif">         
</span>J’ai ajouté la licence, ouvert la console, vérifier le paramétrage de la console, puis généré un agent<o:p></o:p></p>
<p class="MsoListParagraph" style="text-indent:-18.0pt">-<span style="font-size:7.0pt;font-family:"Times New Roman",serif">         
</span><u>1<sup>er</sup> problème</u> : l’agent porte exactement le même numéro de version que l’ancien agent lorsque j’étais en community: 1.7.4.6143-23<o:p></o:p></p>
<p class="MsoListParagraph" style="text-indent:-18.0pt">-<span style="font-size:7.0pt;font-family:"Times New Roman",serif">         
</span>J’édite donc le package et j’incrémente le numéro (-24)<o:p></o:p></p>
<p class="MsoListParagraph" style="text-indent:-18.0pt">-<span style="font-size:7.0pt;font-family:"Times New Roman",serif">         
</span>Je modifie mes GPO afin de mettre à jour le hash…<o:p></o:p></p>
<p class="MsoListParagraph" style="text-indent:-18.0pt">-<span style="font-size:7.0pt;font-family:"Times New Roman",serif">         
</span><u>2eme problème</u> : à l’extinction des postes, ils voient bien la MAJ du package waptupgrade (en -24) mais celui-ci ne fait rien car le wapt community installé a le même numéro de version que celui de mon package 1.7.4.6143<o:p></o:p></p>
<p class="MsoNormal"> <o:p></o:p></p>
<p class="MsoNormal">J’ai loupé un truc quelque part ? <span style="font-family:Wingdings">J</span><o:p></o:p></p>
<p class="MsoNormal">Bonne fin de journée<o:p></o:p></p>
<p class="MsoNormal"> <o:p></o:p></p>
<p class="MsoNormal" style="margin-bottom:12.0pt"><o:p> </o:p></p>
<pre>_______________________________________________<o:p></o:p></pre>
<pre>WAPT mailing list<o:p></o:p></pre>
<pre><a href="mailto:WAPT@lists.tranquil.it">WAPT@lists.tranquil.it</a><o:p></o:p></pre>
<pre><a href="http://lists.tranquil.it/listinfo/wapt" target="_BLANK">http://lists.tranquil.it/listinfo/wapt</a><o:p></o:p></pre>
</blockquote>
<p class="MsoNormal"><span style="font-size:12.0pt;font-family:"Times New Roman",serif"> </span><o:p></o:p></p>
</div>
</body>
</html>