<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<meta name="Generator" content="Microsoft Word 15 (filtered medium)">
<style><!--
/* Font Definitions */
@font-face
        {font-family:Wingdings;
        panose-1:5 0 0 0 0 0 0 0 0 0;}
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0cm;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif;
        mso-fareast-language:EN-US;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:#0563C1;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:#954F72;
        text-decoration:underline;}
p.MsoListParagraph, li.MsoListParagraph, div.MsoListParagraph
        {mso-style-priority:34;
        margin-top:0cm;
        margin-right:0cm;
        margin-bottom:0cm;
        margin-left:36.0pt;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif;
        mso-fareast-language:EN-US;}
p.msonormal0, li.msonormal0, div.msonormal0
        {mso-style-name:msonormal;
        mso-margin-top-alt:auto;
        margin-right:0cm;
        mso-margin-bottom-alt:auto;
        margin-left:0cm;
        font-size:12.0pt;
        font-family:"Times New Roman",serif;}
span.EmailStyle19
        {mso-style-type:personal-compose;
        font-family:"Calibri",sans-serif;
        color:windowtext;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-size:10.0pt;
        font-family:"Calibri",sans-serif;
        mso-fareast-language:EN-US;}
@page WordSection1
        {size:612.0pt 792.0pt;
        margin:70.85pt 70.85pt 70.85pt 70.85pt;}
div.WordSection1
        {page:WordSection1;}
/* List Definitions */
@list l0
        {mso-list-id:594898374;
        mso-list-type:hybrid;
        mso-list-template-ids:-129757440 698377818 67895299 67895301 67895297 67895299 67895301 67895297 67895299 67895301;}
@list l0:level1
        {mso-level-start-at:0;
        mso-level-number-format:bullet;
        mso-level-text:-;
        mso-level-tab-stop:none;
        mso-level-number-position:left;
        text-indent:-18.0pt;
        font-family:"Calibri",sans-serif;
        mso-fareast-font-family:Calibri;}
@list l0:level2
        {mso-level-number-format:bullet;
        mso-level-text:o;
        mso-level-tab-stop:none;
        mso-level-number-position:left;
        text-indent:-18.0pt;
        font-family:"Courier New";}
@list l0:level3
        {mso-level-number-format:bullet;
        mso-level-text:\F0A7;
        mso-level-tab-stop:none;
        mso-level-number-position:left;
        text-indent:-18.0pt;
        font-family:Wingdings;}
@list l0:level4
        {mso-level-number-format:bullet;
        mso-level-text:\F0B7;
        mso-level-tab-stop:none;
        mso-level-number-position:left;
        text-indent:-18.0pt;
        font-family:Symbol;}
@list l0:level5
        {mso-level-number-format:bullet;
        mso-level-text:o;
        mso-level-tab-stop:none;
        mso-level-number-position:left;
        text-indent:-18.0pt;
        font-family:"Courier New";}
@list l0:level6
        {mso-level-number-format:bullet;
        mso-level-text:\F0A7;
        mso-level-tab-stop:none;
        mso-level-number-position:left;
        text-indent:-18.0pt;
        font-family:Wingdings;}
@list l0:level7
        {mso-level-number-format:bullet;
        mso-level-text:\F0B7;
        mso-level-tab-stop:none;
        mso-level-number-position:left;
        text-indent:-18.0pt;
        font-family:Symbol;}
@list l0:level8
        {mso-level-number-format:bullet;
        mso-level-text:o;
        mso-level-tab-stop:none;
        mso-level-number-position:left;
        text-indent:-18.0pt;
        font-family:"Courier New";}
@list l0:level9
        {mso-level-number-format:bullet;
        mso-level-text:\F0A7;
        mso-level-tab-stop:none;
        mso-level-number-position:left;
        text-indent:-18.0pt;
        font-family:Wingdings;}
ol
        {margin-bottom:0cm;}
ul
        {margin-bottom:0cm;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->
</head>
<body lang="FR" link="#0563C1" vlink="#954F72">
<div class="WordSection1">
<p class="MsoNormal">Bonjour tout le monde,<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">Nous rencontrons un soucis sur le déploiement de la 1.5 (en écrasement de la 1.3) par GPO.<o:p></o:p></p>
<p class="MsoNormal">Voici notre architecture :<o:p></o:p></p>
<p class="MsoListParagraph" style="text-indent:-18.0pt;mso-list:l0 level1 lfo2"><![if !supportLists]><span style="mso-list:Ignore">-<span style="font:7.0pt "Times New Roman"">         
</span></span><![endif]>Postes clients en Windows 7, dans un domaine Samba AD, et avec wapt 1.3<o:p></o:p></p>
<p class="MsoListParagraph" style="text-indent:-18.0pt;mso-list:l0 level1 lfo2"><![if !supportLists]><span style="mso-list:Ignore">-<span style="font:7.0pt "Times New Roman"">         
</span></span><![endif]>2 serveurs distincts wapt 1.3 et 1.5<o:p></o:p></p>
<p class="MsoListParagraph" style="text-indent:-18.0pt;mso-list:l0 level1 lfo2"><![if !supportLists]><span style="mso-list:Ignore">-<span style="font:7.0pt "Times New Roman"">         
</span></span><![endif]>« Toujours attendre le réseau lors du démarrage de l’ordinateur et de l’ouverture de session » activé par GPO<o:p></o:p></p>
<p class="MsoListParagraph" style="text-indent:-18.0pt;mso-list:l0 level1 lfo2"><![if !supportLists]><span style="mso-list:Ignore">-<span style="font:7.0pt "Times New Roman"">         
</span></span><![endif]>Nouvelle GPO que l’on applique à qq OU de tests : --hash=665[…]391 --minversion=1.5.1.23 --wait=15 --waptsetupurl=waptagent.exe --setupargs=/dnsdomain=educationetformation.fr --setupargs=/wapt_server= --setupargs=/repo_url= --setupargs=/hiberboot_enabled=0
 --setupargs=/pre_shutdown_timeout=180 --setupargs=/max_gpo_script_wait=180 <o:p>
</o:p></p>
<p class="MsoListParagraph" style="text-indent:-18.0pt;mso-list:l0 level1 lfo2"><![if !supportLists]><span style="mso-list:Ignore">-<span style="font:7.0pt "Times New Roman"">         
</span></span><![endif]>Waptagent et waptdeploy sont tous les 2 dans le dossier startup script de la GPO<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">Notre problème : les postes ne se mettent pas à jour en 1.5 <o:p></o:p></p>
<p class="MsoNormal">Par tâtonnement, voici les différents tests que nous avons effectué :<o:p></o:p></p>
<p class="MsoListParagraph" style="text-indent:-18.0pt;mso-list:l0 level1 lfo2"><![if !supportLists]><span style="mso-list:Ignore">-<span style="font:7.0pt "Times New Roman"">         
</span></span><![endif]>Plusieurs redémarrage des postes<o:p></o:p></p>
<p class="MsoListParagraph" style="text-indent:-18.0pt;mso-list:l0 level1 lfo2"><![if !supportLists]><span style="mso-list:Ignore">-<span style="font:7.0pt "Times New Roman"">         
</span></span><![endif]>Ajout de « > C:\wapt\upgrade.txt » à la fin des paramètres waptdeploy … sauf que windows n’est pas Unix, et que le fichier upgrade.txt n’est écrit que si la commande waptdeploy se termine.. ce qui n’est pas le cas<o:p></o:p></p>
<p class="MsoListParagraph" style="text-indent:-18.0pt;mso-list:l0 level1 lfo2"><![if !supportLists]><span style="mso-list:Ignore">-<span style="font:7.0pt "Times New Roman"">         
</span></span><![endif]>Ajout de GPSvcDebugLevel en base de registre afin d’être un peu plus verbose sur l’application des GPO mais malgré la taille du fichier Gpsvc.log, rien de probant pour nous aider à debug<o:p></o:p></p>
<p class="MsoListParagraph" style="text-indent:-18.0pt;mso-list:l0 level1 lfo2"><![if !supportLists]><span style="mso-list:Ignore">-<span style="font:7.0pt "Times New Roman"">         
</span></span><![endif]>On a joué avec les GPO « Spécifier la durée d’attente maximale pour les scripts de stratégie de groupe », « Executer les scripts de démarrage de manière asynchrone », « Spécifier le temps d’attente de traitement de stratégie de démarrage »
 mais le problème persistait<o:p></o:p></p>
<p class="MsoListParagraph" style="text-indent:-18.0pt;mso-list:l0 level1 lfo2"><![if !supportLists]><span style="mso-list:Ignore">-<span style="font:7.0pt "Times New Roman"">         
</span></span><![endif]>On a viré le « --wait=15 » des paramètres de waptdeploy, qui d’après le code source, correspondrait a faire un --wait=0, et donc à ne pas attendre<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">Au niveau des processus, on a noté qq chose de bizarre : un process waptagent.tmp (correspondant au fichier %windir%\temp\is-fdsfgsdqgfq.tmp) qui ne fait pas grand-chose (0% CPU, 4Mo de Ram utilisé)<o:p></o:p></p>
<p class="MsoNormal">Sinon, on a bien un processus waptdeploy qui lui provient de
<a href="file://mondomain/%5b...%5d/Polices/%5b...%5d/startup/">\\mondomain\[...]\Polices\[...]\startup\</a> et également un processus waptagent.exe (l’exécutable se trouve dans %windir%\Temp)<o:p></o:p></p>
<p class="MsoNormal">Jusque l’a rien d’anormal si ce n’est le waptagent.tmp qui ne fait rien…<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">Cela nous a amené a regardé du côté des services  et à voir que le service WAPTService (nssm.exe) était arrété (type de démarrage automatique).<o:p></o:p></p>
<p class="MsoNormal">A ce stade, si on redémarre le poste, le problème se reproduit. Si on kill les taches de l’installeur (waptdeploy, agent) et qu’on lance le waptdeploy avec les paramètres à la main, l’installation fonctionne !<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">Dernier essai qui nous amène sur une piste intéressante :<o:p></o:p></p>
<p class="MsoListParagraph" style="text-indent:-18.0pt;mso-list:l0 level1 lfo2"><![if !supportLists]><span style="mso-list:Ignore">-<span style="font:7.0pt "Times New Roman"">         
</span></span><![endif]>On démarre un poste en Wapt 1.3 mais sans GPO WApt<o:p></o:p></p>
<p class="MsoListParagraph" style="text-indent:-18.0pt;mso-list:l0 level1 lfo2"><![if !supportLists]><span style="mso-list:Ignore">-<span style="font:7.0pt "Times New Roman"">         
</span></span><![endif]>On change le type de démarrage de WAPTService en désactivé<o:p></o:p></p>
<p class="MsoListParagraph" style="text-indent:-18.0pt;mso-list:l0 level1 lfo2"><![if !supportLists]><span style="mso-list:Ignore">-<span style="font:7.0pt "Times New Roman"">         
</span></span><![endif]>On éteint le poste, et on met la GPO Wapt 1.5<o:p></o:p></p>
<p class="MsoListParagraph" style="text-indent:-18.0pt;mso-list:l0 level1 lfo2"><![if !supportLists]><span style="mso-list:Ignore">-<span style="font:7.0pt "Times New Roman"">         
</span></span><![endif]>On rallume le poste, l’installation fonctionne…<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">Du coup, nous constatons que le « waptagent.tmp » arrive bien à stopper le service WAPTService mais qu’ensuite l’installation ne va pas plus loin…<o:p></o:p></p>
<p class="MsoNormal">Auriez-vous rencontré des cas similaires ? avez-vous quelques pistes à nous suggérer ?<o:p></o:p></p>
<p class="MsoNormal">Bien évidemment, on pourrait faire cette migration 1.3 -> 1.5 de mille manières (au shutdown, par tache planifiée ou meme par un paquet provenant de la 1.3) mais pour le coup, on essaie simplement d’utiliser les préconisations du Wiki.<o:p></o:p></p>
<p class="MsoNormal">En vous remerciant d’avance pour toutes les précisions que vous pourrez nous apporter.<o:p></o:p></p>
<p class="MsoNormal">Bien cordialement<o:p></o:p></p>
<p class="MsoNormal">Jordi<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
</div>
</body>
</html>